Un cambio en WordPress puede “romper” tu web

Por primera vez en años se va a producir un cambio en la versión de PHP considerada como mínima para poder ejecutar una página desarrollada en WordPress. Así, según Zdnet, a partir del próximo mes de diciembre de 2019, la versión mínima de PHP necesaria para ello será la 7.0. El salto será gradual, porque en abril se cambiará la versión mínima de PHP requerida para ejecutar una web en WordPress de la 5.2, la actual, a la 5.6. Por lo que será necesario actualizarlo, con el problema de que si alguno de los plugins que integra no son compatibles con esta versión, la web puede dejar de funcionar.

Por ello, y debido a que todavía hay una gran mayoría de sitios de WordPress que utilizan versiones de PHP anteriores, el CMS comenzará a mostrar advertencias sobre la actualización de PHP en el panel de administración del CMS de las webs que no tengan actualizada la versión de PHP. Según los planes de la entidad, se mostrarán para todos los sites que utilicen una versión de PHP anterior a la 5.6. Los avisos llevarán un enlace a una web de soporte de WordPress con información para los propietarios de las webs, en la que se detalla como pueden actualizar la versión de PHP de su servidor.

La decisión de mostrar estos avisos se tomó el pasado mes de diciembre, después del lanzamiento de WordPress 5.0. Varios días después del lanzamiento, los responsables de WordPress compilaron las primeras estadísticas de actualización de los sistemas, y se dieron cuenta de que el 85% de los usuarios de WordPress 5.0 estaban ejecutando sus webs en versiones 5.6 y superiores.

Por lo tanto, es posible que sólo tengan que actualizarse menos de la mitad de las webs de la comunidad activa de WordPress. Eso sí, hasta ahora sólo se ha hablado de la comunidad activa, porque hay millones de webs con versiones de WordPress antiguas. De ellas, la mayoría están abandonadas, por lo que pueden tener problemas de funcionamiento en el futuro.

En cualquier caso, el aviso para la actualización de PHP comenzará a aparecer con la llegada de WordPress 5.1, cuyo lanzamiento está previsto para principios de primavera. Los planes de la comunidad de WordPress pasan por migrar a las versiones de PHP más recientes a cuantos usuarios activos de WordPress puedan, con el objetivo de que el equipo pueda abandonar el soporte para las versiones antiguas de PHP cuanto antes.

Al equipo les gustaría modificar las versiones mínimas de ejecución de PHP, como hemos visto, para abril y diciembre. También tienen planes de hacer lo mismo con MySQL, subiendo hasta su versión 5.5 como la mínima necesaria para ejecutar WordPress.

Los cambios se deben a que el equipo de PHP ha decidido dejar de prestar soporte para problemas de seguridad a las versiones 5.6 y 7.0 de PHP. Los servidores que lo utilicen, por tanto, son ahora vulnerables a ataques y exploits masivos.

Esto supone un problema serio, puesto que alrededor del 66,7% de los sites con WordPress utilizan una versión de PHP que no cuenta con soporte técnico, según W3Techs. Y si se tiene en cuenta que más de la cuarta parte de los sitios de Internet utilizan el CMS WordPress, se puede tener una idea aproximada de la magnitud del problema.

Publicado en Informatica.

Deja un comentario